
《地理与地理信息系统实验》教案

一、课程的性质和任务

该课程面向生态学专业的学生开设的实验课程，旨在加深学生对 GIS 的基本

概念、GIS 的数据结构、GIS 数据输入存储编辑方法、GIS 空间分析方法等知识

点的认识；懂得如何利用 GIS 研究和解决地学问题的思路；熟练掌握 ArcGIS 软

件的操作和应用。

二、课程的基本要求

《GIS 实验》是《地理信息系统》课程教学的重要组成部分，通过实验，使

学生加深对 GIS 基本理论的理解，提升学生的动手能力；实验目标是要加深学生

对 GIS 的基本概念、GIS 的数据结构、GIS 数据输入存储编辑方法、GIS 空间分

析方法等知识点的认识；懂得如何利用 GIS 研究和解决地学问题的思路；熟练掌

握 ArcGIS 软件的操作和应用。

三、适用专业

生态学

四、预修课程

普通生态学

五、学时（按章分）

六、教授内容



一、实验目的

Ø 了解空间数据是如何进行组织及基于“图层”进行显示的。

Ø 认识ArcMap图形用户界面。

Ø 通过浏览与空间实体关联的数据表，可以了解空间数据是

如何与其属性信息进行连接的。

Ø 掌握GIS两中基本查询操作，加深对其实现原理的理解。

Ø 学会使用ArcGis创建和编辑矢量数据



二、实验准备

Ø 软件准备：确保你的计算机中已经正确安装了ArcGIS 

Desktop 10.0软件（ArcView，ArcEditor或ArcInfo）。

Ø 实验数据――中国省界、中国主要铁路和地级市驻地



三、实验步骤及方法

p ARCGIS界面简介

第一步   启动ArcMap



p ARCGIS界面简介

第一步   启动ArcMap



p ARCGIS界面简介

ArcMap窗口



p ARCGIS界面简介

主菜单

窗口标准工具

地图浏览工具



p ARCGIS界面简介

内容列表窗口 地图显示窗口



p ARCGIS界面简介

按绘制顺序 按源列出 按可见性 按选择要素



p ARCGIS界面简介

数据视图 布局视图



p ARCGIS界面简介

搜索界面



p ARCGIS界面简介

目录界面



p ARCGIS界面简介

显示方式



p 使用ARCGIS浏览数据



p 使用ARCGIS浏览数据



p 使用ARCGIS浏览数据



p 使用ARCGIS浏览数据
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p 使用ARCGIS浏览数据

空间查询



p 使用ARCGIS浏览数据

空间查询



p 使用ARCGIS浏览数据

属性查询



p 使用ARCGIS浏览数据

属性查询



p 使用ARCGIS浏览数据

属性查询



p 使用ARCGIS浏览数据

属性查询



p 使用ARCGIS浏览数据

属性查询



p 使用ARCGIS浏览数据

属性查询
属性字段

查询符号

查询公式

字段值显示
窗口



p 使用ARCGIS浏览数据

属性查询



p 使用ARCGIS创建和编辑数据

1.创建一个
Shapefile



p 使用ARCGIS创建和编辑数据

2.创建一个线图层，并命名这
个图层为河南省行政区划



p 使用ARCGIS创建和编辑数据

3.加载河南
省行政区划
图



4.调出编辑
器工具条

p 使用ARCGIS创建和编辑数据



5.点击编辑
器-开始编辑

p 使用ARCGIS创建和编辑数据



p 使用ARCGIS创建和编辑数据
编辑条工具

变亮



p 使用ARCGIS创建和编辑数据

删除整条线

撤销



p 使用ARCGIS创建和编辑数据

双击鼠标完成
一条线的编辑

画线的时候线
要交叉



p 使用ARCGIS创建和编辑数据

要记得随时保存编辑内容！！！



p 使用ARCGIS创建和编辑数据

使用搜索窗
口找到“要
素转面”工
具



p 使用ARCGIS创建和编辑数据



Ø ARCGIS加载数据和浏览数据

Ø ARCGIS空间查询和属性查询的方法

Ø 完成河南省行政区划图的数字化



一、实验目的

使学生了解符号化、注记标注、格网绘制及地图整

饰的意义，掌握基本的符号化方法、自动标注操作

及相关地图的整饰和输出的操作。对数字地图有初

步的认识。



二、实验数据

上海市部分地区矢量地图，其中包含：

（1）点图层：区县政府（QXZF.shp），市政府

（SZF.shp）；

（2）线图层：地铁线（DTX.shp），区县界限

（QXJX.shp），道路（DL.shp）；

（3）面图层：区县界面（QXJM.shp），双线河（SXH.shp）

数据存放在……\Chp5\Ex1中



三、实验步骤

1 数据符号化

1.1 双击……\Chp5\Ex1\shanghai.mxd地图文档，打开ArcMap

1.2 根据排序规则对图层排序







三、实验步骤

1 数据符号化

1.3 点线面符号的设置



双击这里



设置点的
样式

设置点的
颜色

设置点的
大小



双击这里



设置线的
样式

设置线的
颜色

设置线的
宽度



设置面的
样式

设置面的
填充颜色

设置轮廓
线的宽度

设置轮廓
线的颜色





双击这里



画面好熟悉
的赶脚。。。



三、实验步骤

2 地图标注



看这里！看这里！



选择标注字段

设置字体显示样式

设置好后点
确定



空白处右键





三、实验步骤

3 设置格网



点这里切换成
布局视图



有什么不
一样





点这里！点这
里！









多了个
“经纬网”

点击确定





三、实验步骤

4 设置图例



点击插入



显示了软件中
的所有数据

显示需要生成
图例的数据























一、实验背景

如何找到环境好、购物方便、小孩上学方便的居住

区地段是购房者最关心的问题，因此购房者就需要

从总体上对商品房的信息进行研究分析，选择最适

宜的购房地段



二、实验目的

学会使用缓冲区分析和叠置分析解决实际问题



三、实验数据

（1）城市市区交通网络图（network.shp）；

（2）商业中心分布图（marketplace.shp）；

（3）名牌高中分布图（school.shp）；

（4）名胜古迹分布图（famous place.shp）

数据存放在……\Chp7\Ex1中



四、实验步骤

1 主干道缓冲区建立





四、实验步骤

1主干道缓冲区建立

1.1 双击……\Chp7\Ex1\city.mxd地图文档，打开ArcMap

1.2 选择城市主干道





1、单击这里

2、单击这里

3、单击这里

4、单击这里







四、实验步骤

1主干道缓冲区建立

1.3 建立主干道缓冲区







1、单击这里选择
缓冲区距离单位

2、设置缓冲距离
为200



设置好保存路径





四、实验步骤

2 其他缓冲区建立

2.1 以同样的方法建立商业中心、名牌高中和名胜古迹的缓冲区



商业中心缓冲区

这 里 有 点 不 一
样！！











四、实验步骤

3 叠置分析

3.1 进行叠置分析，将满足上述四个要求的区域求出















四、实验步骤

4 分等定级

4.1 为了使结果更有说服力，更加直观，对整个市区进行分等
定级











记得保存哦！！！



四、实验步骤

4 分等定级

4.2 以同样的方法对其他缓冲区添加字段和赋值



四、实验步骤

4 分等定级

4.3 对四个缓冲区进行叠置分析















一、实验背景

由于空间数据（包括地形图与DEM）都是分幅存储

的，某一特定研究区域常常跨越不同图幅。当要获

取由特定边界的研究区域时，就要对数据进行裁切、

拼接、提取等操作，有时还要进行相应的投影变换。



二、实验目的

通过练习，掌握数据提取、裁切、拼接及投影变换

的方法。



三、实验数据

（1）矢量数据（Vector.shp）：白水县的行政范围；

（2）DEM数据（ DEM 1和DEM 2）；

数据存放在……\Chp4\Ex1中



四、实验步骤

1 白水县行政范围的提取







单击这里







四、实验步骤

2 DEM数据拼接









四、实验步骤

3 利用白水县范围对DEM裁切







四、实验步骤

4 白水县DEM投影变换



这是什么坐
标系







单击这里











一、实验背景

合理的学校空间位置布局，有利于学生的上课与生

活。学校的选址问题需要考虑地理位置、学生娱乐

场所配套、与现有学校的距离间隔等因素，从总体

上把握这些因素能够确定出适宜性比较好的学校选

址区



二、实验目的

通过练习，熟悉ARCGIS栅格数据距离制图、成本距

离加权、数据重分类、多层面合并等空间分析功能；

熟练掌握利用ARCGIS空间分析功能，分析和结果类

似学校选址的实际应用问题。



三、实验数据

（1）landuse（土地利用图）

（2）dem（地面高程图）

（3）rec_sites（娱乐场所分布图）

（4）school（现有学校分布图）

数据存放在……\Chp8\Ex1中



四、实验要求

（1）新学校选址需注意如下几点：地势平坦；结合现有土

地利用类型考虑，成本不高的区域；与现有娱乐设施相配

套；避开现有学校，合理分布

（2）各数据层权重比：距离娱乐设施占0.5，距离学校占

0.25，土地利用类型和地势位置各占0.125

（3）熟练运用如下功能：坡度计算、直线距离制图、重分

类和栅格计算器

（4）给出适合新建学校的适宜地区图



五、实验步骤

1 准备数据

1.1 工作环境设置











五、实验步骤

1 准备数据

1.2 坡度分析







五、实验步骤

1 准备数据

1.3 娱乐场所距离分析









五、实验步骤

1 准备数据

1.4 学校距离分析





五、实验步骤

2 重分类数据

2.1 重分类坡度数据





单击这里



单击这里，选择
相等间隔



五、实验步骤

2 重分类数据

2.2 重分类娱乐场所距离图







五、实验步骤

2 重分类数据

2.3 重分类学校距离图







五、实验步骤

2 重分类数据

2.4 重分类土地利用图





五、实验步骤

3 栅格计算









一、实验背景

各地区经济协调发展是保证国民经济健康持续稳定

增长的关键。GDP是反映各地区经济发展状况的重要

指标。科学准确分析各地区GDP空间分布特征，对制

定有效措施，指导经济协调发展具有重要参考价值。



二、实验目的

ARCGIS中提供了三种空间插值方法，每种插值方法

在原理和应用上都大不相同，在此通过具体实例练

习如何利用反距离权重内插方法和样条函数内插方

法进行GDP空间分布特征的分析。



三、实验步骤

1 反距离权重插值

1.1 打开地图文档





三、实验步骤

1 反距离权重插值

1.2 工作环境设置





三、实验步骤

1 反距离权重插值

1.3 反距离权重插值





在IDW插值之前,我们可以事

先获取一个离散点子集，用

于计算插值的权重；

原因1：离散点距离插值点

越远，其对插值点的影响力

越低，甚至完全没有影响力；

原因2：离散点越少可以加

快运算速度；







修改这里





三、实验步骤

1 反距离权重插值

1.4 插值结果比较







三、实验步骤

2 样条函数插值

2.1 Regularized函数不同权重的比较













三、实验步骤

2 样条函数插值

2.2 Tension函数不同权重的比较













三、实验步骤

3 其他插值方法

3.1 克里金插值法







三、实验步骤

3 其他插值方法

3.2 自然邻域法







三、实验步骤

3 其他插值方法

3.2 克里金插值法









一、实验背景

现有某地区一系列高程采样点，需要通过内插生成

该地区的高程层面，为后续研究提供合理的数据层

面信息。



二、实验目的

地统计模块中提供了六种克里金插值方法，每种方

法的原理及适用范围不尽相同。通过练习熟练掌握

并理解每种克里金方法的原理及实现过程，体会在

具体应用中的适应性



三、实验步骤

1 数据探查

实验数据存放在…… \Chp10\Ex1



















三、实验步骤

2 数据插值







单击这里

单击这里

单击这里













三、实验步骤

3 结果检验
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图像几何校正 
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1. 概述 

几何校正是利用地面控制点和几何校正数学模型来矫正非系统因素产生的误差，由于校正

过程中会将坐标系统赋予图像数据，所以此过程包括了地理编码。  

在开始介绍 ENVI的几何校正操作之前，首先对 ENVI的几何校正几个功能要点做一个说明。 

1.1 控制点选择方式 

ENVI 提供以下选择方式： 

（1） 从栅格图像上选择 

如果拥有需要校正图像区域的经过校正的影像、地形图等栅格数据，可以从中选择控制点，

对应的控制点选择模式为 Image to Image。 

（2） 从矢量数据中选择 

如果拥有需要校正图像区域的经过校正的矢量数据，可以从中选择控制点，对应的模式为

Image to Map。 

（3） 从文本文件中导入 

事先已经通过GPS 测量、摄影测量或者其他途径获得了控制点坐标数据，保存为以[Map (x,y), 

Image (x,y)]格式提供的文本文件可以直接导入作为控制点，对应的控制点选择模式为 Image to 

Image 和 Image to Map。 

（4） 键盘输入 

如果只有控制点目标坐标信息或者只能从地图上获取坐标文件（如地形图等），只好通过键

盘敲入坐标数据并在影像上找到对应点。 

1.2 几何校正模型 

ENVI 提供三个几何校正模型：仿射变换（RST）、多项式和局部三角网（Delaunay Triangulation）。 

1.3 控制点的预测与误差计算 

控制点的预测是通过控制点回归计算求出多项式系数，然后通过多项式计算预测下一个控

制点位置，RMS 值也是用同样的方法。默认多项式次数为 1，因此在选择第四个点时控制点预

测功能可以使用，随着控制点数量的增强，预测精度随之增加。最少控制点数量与多项式次数
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的关系为（n+1）2。 

本课程使用的数据列表如下： 

表 1.1 练习数据说明 

文件 说明 

5wDRG\taian-drg.tif 1:5 万地形图数据 

5wDRG\GCP.pts 包括 9 个控制点的控制点文件 

TM 与 spot\bldr_sp.img(和.hdr) 带有地理坐标的、10 米分辨率的 SPOT 全色图像 

TM 与 spot\bldr_tm.img(和.hdr) 没有地理坐标、30 米分辨率的 TM 多光谱图像 

points.pts 控制点文件 

2. 详细操作步骤 

2.1 扫描地形图的几何校正 

第一步：打开并显示图像文件 

开始>程序>ENVI5.1>Tools>ENVI Classic，选择主菜单>File>Open Image File，将 taian-drg.tif

文件打开，并显示在 Display 中。 

第二步：启动几何校正模块 

（1） 主菜单>Map>Registration>Select GCPs:Image to map，打开几何校正模块。 

（2） 在 Image to Map Registration 面板中，选择 Beijing_1954_GK_Zone_20，X/Y Pixel Size

分别输入 4，单击 O K，打开 Ground Control Points Selection 面板。 

注：国内坐标系直接使用“国内坐标系文件”中的内容。 
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图2.1 选择坐标系及输出网格大小 

（3） 在 Displsy 视图中，定位到左上角第一个公里网交互处，从图上读取 X：20501000，

Y：4003000，填入在 Image to Map Registration 面板中的 E 和 N，单击 Add Point 按钮，

增加第一个控制点。 

 

图2.2 读取控制点坐标信息并手动输入 

（4） 在 Displsy 视图中，向右平移 10 个公里网，即到 X：20511000 处，在 Image to Map 
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Registration 面板中 E：20511000 和 N：4003000。单击 Add Point 按钮，增加一个控制点。 

（5） 当选择 3 个点时候，Pretict 按钮亮起，可以在 E 和 N 中输入坐标，单击 Pretict 按钮

自动在图上大致定位，或者选择 Options>Auto Pretict，可以自动根据坐标值在图上定位。 

（6） 同样的方法，在图上均匀添加 9 个控制点。 

（7） 在 Ground Control Points Selection 上，选择 Options>Warp File，选择校正文件

taian-drg.tif，点击 OK。 

（8） 在校正参数面板中，校正方法选择多项式（2 次）。 

（9） 重采样选择 Bilinear，背景值（Background）为 0。 

（10） 选择输出路径和文件名，单击 Ok 按钮。 

 
图2.3 参数输出设置面板 

2.2 Landsat5 影像几何校正 

下面学习以具有地理参考的 SPOT4 10 米全色波段为基准影像，对 Landsat5 TM 30 米图像的

几何精校正过程，文件都是以 ENVI 标准栅格格式储存，数据存放在“04.遥感图像几何校正\数

据\TM 与 spot”文件夹内，其流程如下图所示： 
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图2.4 几何校正一般流程 

第一步：打开并显示图像文件 

开始>程序>ENVI5.1>Tools>ENVI Classic，主菜单>File>Open Image File，将 SPOT（bldr_sp.img）

和 TM 图像（bldr_tm.img）文件打开，并分别在 Display 中显示两个影像。 

第二步：启动几何校正模块 

（1） 主菜单>Map>Registration>Select GCPs:Image to Image，打开几何校正模块。 

（2） 选择显示 SPOT 文件的 Display 为基准影像（Base Image），显示 TM 文件的 Display 为待

校正影像（Warp Image），点击 OK 进入采集地面控制点。 

 
图2.5 选择基准与待校正影像 

第三步：采集地面控制点 

（1） 在两个 Display 中找到相同区域，在 Zoom 窗口中，点击左小下角第三个按钮 ，打开
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定位十字光标，将十字光标到相同点上，点击 Ground Control Points Selection 上的 Add Point

按钮，将当前找到的点加入控制点列表。 

（2） 用同样的方法继续寻找其余的点，当选择控制点的数量达到 3 时，RMS 被自动计算。

Ground Control Points Selection 上的 Predict 按钮可用，选择 Options>Auto Predict，打开自动

预测功能。这时在 Base Image（Spot 影像）上面定位点，Warp Image（TM 影像）上会自动

预测区域。 

（3） 当选择一定数量的控制点之后（至少 3 个），可以利用自动找点功能。Ground Control 

Points Selection 上，选择 Options>Automatically Generate Points，选择一个匹配波段，这里

选择 band5，点击 OK，弹出自动找点参数设置面板，设置 Tie 点的数量为 50，Search Window 

Size 为 131，其他选择默认参数，点击 OK。 

 

图2.6 Tie 点自动选择参数设置 

（4） 点击 Ground Control Points Selection 上的 Show List 按钮，可以看到选择的所有控制列表，

如下图所示。选择 Image to Image GCP  List 上的 Options>Order Points by Error，按照 RMS

值有高到底排序。 
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图2.7 控制点列表 

（5） 对于 RMS 过高的点，一是直接删除：选择此行，按 Delete 按钮；二是在两个影像的 ZOOM

窗口上，将十字光标重新定位到正确的位置，点击 Image to Image GCP  List 上的 Update 按

钮进行微调，这里直接做删除处理。 

（6） 总的 RMS 值小于 1 个像素时，完成控制点的选择。点击 Ground Control Points Selection

面板上的 File>Save GCPs to ASCII，将控制点保存。 

第四步：选择校正参数输出 

有两种校正输出方式：Warp File 和 Warp File (as Image Map)。推荐使用 Warp File (as Image 

Map)。 

 Warp File 

（1） 在 Ground Control Points Selection 上，选择 Options->Warp File，选择校正文件(TM

文件)。 

（2） 在校正参数面板中，校正方法选择多项式（2 次）。 

（3） 重采样选择 Bilinear，背景值（Background）为 0. 

（4） Output Image Extent：默认是根据基准图像大小计算，可以做适当的调整。 

（5） 选择输出路径和文件名，单击 Ok 按钮。 

 这种校正方式得到的结果，它的尺寸大小、投影参数和像元大小（如果基准图像有投影）都和

基准图像一致。 
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图2.8 Warp File 校正参数设置 

 Warp File (as Image Map) 

（1） 在 Ground Control Points Selection 上，选择 Options> Warp File (as Image to Map) ，

选择校正文件(TM 文件)。 

（2） 在校正参数面板中，默认投影参数和像元大小与基准影像一致。 

（3） 投影参数保持默认，在 X 和 Y 的像元大小输入 30 米，按回车，图像输出大小自动

更改。 

（4） 校正方法选择多项式（2 次）。 

（5） 重采样选择 Bilinear，背景值（Background）为 0. 

（6） Output Image Extent：默认是根据基准图像大小计算，可以做适当的调整。 

选择输出路径和文件名，单击 Ok 按钮。 



  遥感事业部 

网址：www.esrichina.com.cn  技术支持邮箱：ENVI-IDL@esrichina.com.cn  电话：010-57632288  技术支持热线：400-819-2881-7 

 

图2.9 Warp File (as Image to Map)校正参数设置 

第五步：检验校正结果 

检验校正结果的基本方法是：同时在两个窗口中打开图像，其中一幅是校正后的图像，一

幅是基准图像，通过地理链接（Geographic Link）检查同名点的叠加情况。 

在显示校正后结果的 Image 窗口中，右键选择 Geographic Link 命令，选择需要链接的两个

窗口，打开十字光标进行查看，如下图所示。 

或者直接在 ENVI5 新界面下打开两幅图像进行对比。 
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图2.10 检验校正结果 



ArcGIS 10.0 在 DEM 的基础上划分小流域

根据 DEM 提取河流网络，计算流水累积量、流向、根据指定的流域面积大小自动划分

流域

1. 加载 DEM
打开 ArcMap，加载数据 DEM数据文件
如果 DEM 中有很多异常值，可能刚加载进来的时候是全灰或者全白，这个时候需要右

键→图层属性，进行调整。

2. Fill
DEM 表面存在着一些凹陷的区域（DEM 本身是插值计算的，很难与现实情况完全符合），

由于这些区域异常低值存在，使得该区域在进行水流流向计算时得到不合理的水流方向。

因此，应该首先对原始 DEM 数据进行洼地填充，得到无洼地的 DEM。

打开 ArcToolbox中的水文分析模块。使用 Spatial Analyst Tools→Hydrology→Fill
如果没有水文分析模块，请用 Customize→Extensions→Spatial Analyst添加扩展模块。





3. Flow Direction
ArcGIS 中的水流方向利用 D8 算法计算。针对每一个栅格，将其高程与周围八个栅格进

行比较，得到水流方向。最终得到的结果是一个栅格图，每个象元上的值的含义如下图所示。

如果某象元算得的水流方向是正东方向，则值为 1.如果西北，则为 128，以此类推。



注意，这里要用的 DEM 已经不是原始的 DEM 了，需要用经过 Fill 后的 DEM，也就是第

二步生成的结果 DEM。（文件命名不能超过 13 个字符？好像是）

使用 Spatial Analyst Tools→Hydrology→Flow Direction





4. Flow Accumulation
Flow Accumulation 由 Flow Direction 数据计算而来。每一个栅格 Flow Accumulation

的值代表着其上游有多少个栅格的 Flow Direction 最终汇流经过该栅格。一般而言，计

算出来的 Accumulation的数值数值越大，代表越有可能是河谷。

使用 Spatial Analyst Tools→Hydrology→Flow Accumulation





5. 河网计算

当 Flow Accumulation 达到一定值的时候，就会产生地表水流，那么所有那些 Flow
Accumulation 大于阈值的栅格就是潜在的水流路径，由这些水流路径构成的网络，就是

河网。这个阈值是需要人为设定的，与定义的汇水面积有关。这里，我们设置为 10000，
也就是说，如果在某个栅格的上游有 10000 个栅格的水流会流经这个栅格，则将这个栅

格定义为河流。由于本文用的栅格是 30 米×30 米，也就是说，如果某个栅格点，其上

游的汇水面积超过 9 平方公里，则认为这里是河流。

使用 Spatial Analyst Tools→Map Algebra→Raster Calculator







6. Stream link
Stream link 记录着河网中节点之间的连接信息。Stream link 的每条弧段要么连接着两个

作为出水点或汇合点的结点，要么连接着作为出水点的结点和河网起始点。河网节点是

计算流域的输入参数。

使用 Spatial Analyst Tools→Hydrology→Stream Link





7. Watershed
先确定一个出水点，然后结合水流方向数据，分析搜索出该出水点上游所有流过该

出水口的栅格，化为这个出水点之上的流域。这里，我们将第 6 步算出来的河流节点作

为这一步的出水点数据。当然，这样的话计算出的流域将会很破碎，而且得不到流域之

间的隶属关系。如果需要得到更为精确的流域，那么就需要人工去判读出水点。

使用 Spatial Analyst Tools→Hydrology→Watershed







到这一步，就把所有的集水区划分出来了。为了显示的需要，我们还需要将河网加进来，

以显示每个小流域隶属哪一段河道。

8. 将河网转成矢量图

第五步生成的河网图是栅格的，这里需要将其转化为矢量的，以作为图层查看流域。

使用 Spatial Analyst Tools→Hydrology→Stream to Feature





到这里为止，就基本符合要求了。。下面第 9 步之后的东西，是为了以后其他计算的需

要，例如给流域添加属性，计算流域的面积等用的。

9. 将流域的栅格转矢量

Conversion Tools→From Raster→Raster to Polygon



现在就可以做专题图来显示不同的流域了



10. 通过裁剪获得指定范围的栅格图

给定数据，1）栅格图。2）给定范围的面状图层。

加载数据

本例中右一副大范围的 DEM 图，有一个小的面状区域。现在需要获得该小面状范围的

DEM。



打开 ArcToolbox

使用 Data Management Tools→Raster→Raster Processing→Clip
设置相关参数



注意，如果使用的面不是规则矩形，一定要点上“Use Input Features for Clipping
Geometry(optional)
查看结果
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1.概述

监督分类，又称训练分类法，用被确认类别的样本像元去识别其他未知类别像元的过程。它就是在分类之前通过

目视判读和野外调查，对遥感图像上某些样区中影像地物的类别属性有了先验知识，对每一种类别选取一定数量

的训练样本，计算机计算每种训练样区的统计或其他信息，同时用这些种子类别对判决函数进行训练，使其符合

于对各种子类别分类的要求，随后用训练好的判决函数去对其他待分数据进行分类。使每个像元和训练样本作比

较，按不同的规则将其划分到和其最相似的样本类，以此完成对整个图像的分类。

遥感影像的监督分类一般包括以下6个步骤，如下图所示：

图1.1 监督分类步骤

加好友 发纸条

写留言 加关注

ENVI-IDL技术殿堂 

博客等级：

博客积分：183

博客访问：9,303,152

关注人气：7,279

获赠金笔：1181

赠出金笔：0

荣誉徽章：

微博

转 载▼

幻灯播放

ENVI-IDL技术殿堂的博客
ENVI-IDL中国官方微博

http://blog.sina.com.cn/enviidl [订阅] [手机订阅]

首页 博文目录 关于我

西安孕妇写真

武汉孕妇写真

http://blog.sina.com.cn/s/blog_543ad8870102yvdj.html#cre=blogpagepc&mod=f&loc=1&r=0&rfunc=100&tj=none
http://blog.sina.com.cn/u/1413142663
http://blog.sina.com.cn/s/blog_4e22ae2e0102z097.html#cre=blogpagepc&mod=f&loc=2&r=0&rfunc=100&tj=none
http://blog.sina.com.cn/u/1310895662
http://blog.sina.com.cn/s/blog_683c467b0102z1mo.html#cre=blogpagepc&mod=f&loc=3&r=0&rfunc=100&tj=none
http://blog.sina.com.cn/u/1748780667
http://blog.sina.com.cn/s/blog_70db28510102yd2m.html#cre=blogpagepc&mod=f&loc=4&r=0&rfunc=100&tj=none
http://blog.sina.com.cn/u/1893410897
http://blog.sina.com.cn/s/blog_a446ce6101030606.html#cre=blogpagepc&mod=f&loc=5&r=0&rfunc=100&tj=none
http://blog.sina.com.cn/u/2756103777
http://blog.sina.com.cn/s/blog_16ed223410102z82q.html#cre=blogpagepc&mod=f&loc=6&r=0&rfunc=100&tj=none
http://blog.sina.com.cn/u/6154232641
http://blog.sina.com.cn/s/blog_6c33acec0102zfp6.html#cre=blogpagepc&mod=f&loc=7&r=0&rfunc=100&tj=none
http://blog.sina.com.cn/u/1815325932
http://blog.sina.com.cn/s/blog_6ab3eb780102zg75.html#cre=blogpagepc&mod=f&loc=8&r=0&rfunc=100&tj=none
http://blog.sina.com.cn/u/1790176120
http://blog.sina.com.cn/s/blog_691585fa010301gj.html#cre=blogpagepc&mod=f&loc=9&r=0&rfunc=100&tj=none
http://blog.sina.com.cn/u/1763018234
http://blog.sina.com.cn/s/blog_75cea2d60102yye4.html#cre=blogpagepc&mod=f&loc=10&r=0&rfunc=100&tj=none
http://blog.sina.com.cn/u/1976476374
javascript:;
javascript:;
http://news.sina.com.cn/437/2008/0703/24.html
http://search.sina.com.cn/?c=blog&q=%D4%D3%CC%B8&by=tag
http://blog.sina.com.cn/s/articlelist_1984634525_1_1.html
http://saxn.sina.com.cn/dsp/click?t=&userid=219.150.222.29_1460616857.851990&auth=b6f5c763b49af2cc&p=lgOmSagpOhCOlle9EOLTLLOSnNIXSkiOWmAEpA%3D%3D&url=http%3A%2F%2Fsaxn.sina.com.cn%2Fclick%3Fid%3D17%26t%%253D%253D%26type%3D2%26url%3Dhttps%253A%252F%252Fad.qktz.com.cn%252Ftemplate%252Fhtml%252F69%252F5d2eb7de1e869.html%253Freffer%253D339%2526bz%253D1000-90-4%2526SET_A%253DPDPS000000049439%2526SET_B%253D3493809%2526SET_C%253D4091784%2526SET_D%253De1983381-e6de-44f4-8471-50cdd6562abd%2526SET_E%253D3215346%2526SET_F%253D1%26sina_sign%3D683aa44c4a8e94f3&sign=c3b5ea98421d8396
javascript:void(0)
javascript:void(0)
http://blog.sina.com.cn/s/profile_1984634525.html#write
http://blog.sina.com.cn/v/verify
http://blog.sina.com.cn/lm/map/
http://control.blog.sina.com.cn/blog_rebuild/profile/controllers/points_action.php
http://control.blog.sina.com.cn/blog_rebuild/profile/controllers/points_action.php
http://control.blog.sina.com.cn/blog_rebuild/profile/controllers/points_action.php
http://control.blog.sina.com.cn/blog_rebuild/profile/controllers/points_action.php
http://control.blog.sina.com.cn/blog_rebuild/profile/controllers/points_action.php
http://weibo.com/u/1984634525?source=blog
javascript:;
javascript:void(0);
http://blog.sina.com.cn/enviidl
http://blog.sina.com.cn/v/verify
http://blog.sina.com.cn/enviidl
javascript:void(scope.pa_add.add('1984634525'));
http://blog.sina.com.cn/enviidl
http://blog.sina.com.cn/s/articlelist_1984634525_0_1.html
http://blog.sina.com.cn/s/profile_1984634525.html
https://cpro.baidu.com/cpro/ui/uijs.php?en=mywWUA71T1YsFh7sT7qGujYsFhPC5H0huAbqrauGTdq9TZ0qnauJp1dbnvmdm164PWuhnjn1nhcvFh_qFRP7FRmLFRcsFRczFRfYFRfsFRc3FRF7FRfsFRcYFRfdFRRvFhkdpvbqniuVmLKV5HckPHm1FMDqrHcsP1n1PW9xmLKzFMFB5H0hTMnqniu1uyk_ugFxpyfqniu1pyfqmWm1nW01Phm4Phn3uWNbnzu1IA-b5HDkPiuY5gwsmvkGmvV-ujPxpAnhIAfqn1fLPWR4PBuYUgnqnHRLrjfsnW6drauYIHddn1fLPWR4PBud5y9YIZ0-nYD-nbm-nbuBUAqMFHF7Tv-8miRzwyPEUiRzwyP8FMNGUy-b5Hm3PHR3P1R1niuv5HchpHd9njfYPvm3P0&c=news&cf=1&cvrq=600836&expid=200917_202440_202756_202798&fr=14&fv=0&haacp=117&img_typ=6242&itm=0&lu_idc=nj02&lukid=1&lus=b632036f96c8f5d3&lust=5e14842a&lvl=-1&mscf=0&mtids=2015605217,9707391&n=10&nttp=1&p=baidu&sr=317&ssp2=1&tpl=baiduCustNativeADImage&tsf=dtp:1&u=%2Fs%2Fblog%5F764b1e9d0102v22a%2Ehtml&uicf=lurecv&urlid=0&eot=1
https://cpro.baidu.com/cpro/ui/uijs.php?en=mywWUA71T1YsFh7sT7qGujYsFhPC5H0huAbqrauGTdq9TZ0qnauJp1dbnvmdm164PWuhnjn1nhcvFh_qFRP7FRmLFRcsFRczFRfYFRfsFRc3FRF7FRfsFRcYFRfdFRRvFhkdpvbqniuVmLKV5HckPHm1FMDqrHcsP1n1PW9xmLKzFMFB5H0hTMnqniu1uyk_ugFxpyfqniu1pyfqmWm1nW01Phm4Phn3uWNbnzu1IA-b5HDkPiuY5gwsmvkGmvV-ujPxpAnhIAfqn1fLPWR4PBuYUgnqnHRLrjfsnW6drauYIHddn1fLPWR4PBud5y9YIZ0-nYD-nbm-nbuBUAqMFHF7Tv-8miRzwyPEUiRzwyP8FMNGUy-b5Hm3PHR3P1R1niuv5HchpHd9njfYPvm3P0&c=news&cf=1&cvrq=600836&expid=200917_202440_202756_202798&fr=14&fv=0&haacp=117&img_typ=6242&itm=0&lu_idc=nj02&lukid=1&lus=b632036f96c8f5d3&lust=5e14842a&lvl=-1&mscf=0&mtids=2015605217,9707391&n=10&nttp=1&p=baidu&sr=317&ssp2=1&tpl=baiduCustNativeADImage&tsf=dtp:1&u=%2Fs%2Fblog%5F764b1e9d0102v22a%2Ehtml&uicf=lurecv&urlid=0&eot=1
https://cpro.baidu.com/cpro/ui/uijs.php?en=mywWUA71T1YsFh7sT7qGujYsFhPC5H0huAbqrauGTdq9TZ0qnauJp1dbnvmdm164PWuhnjn1nhcvFh_qFRP7FRRYFRFKFRFKFRfYFRfsFRc3FRF7FRfsFRcYFRfdFRRvFhkdpvbqnBuVmLKV5HD4nj6vFMDqrHcsP1n1PW9xmLKzFMFB5H0hTMnqniu1uyk_ugFxpyfqniu1pyfqmWm1nW01Phm4Phn3uWNbnzu1IA-b5HDkPiuY5gwsmvkGmvV-ujPxpAnhIAfqn1fLPWR4PBuYUgnqnHRLrjfsnW6drauYIHddn1fLPWR4PBud5y9YIZ0-nYD-nbm-nbuBUAqMFHF7Tv-8miRzwyPEUiRzwyP8FMNGUy-b5Hm3PHR3P1R1niuv5HchpHY1n1-buhF9u6&c=news&cf=1&cvrq=742333&expid=200917_202440_202756_202798&fr=14&fv=0&haacp=138&img_typ=6246&itm=0&lu_idc=nj02&lukid=2&lus=b632036f96c8f5d3&lust=5e14842a&lvl=-1&mscf=0&mtids=2001892614,2015605217&n=10&nttp=1&p=baidu&sr=317&ssp2=1&tpl=baiduCustNativeADImage&tsf=dtp:1&u=%2Fs%2Fblog%5F764b1e9d0102v22a%2Ehtml&uicf=lurecv&urlid=0&eot=1
https://cpro.baidu.com/cpro/ui/uijs.php?en=mywWUA71T1YsFh7sT7qGujYsFhPC5H0huAbqrauGTdq9TZ0qnauJp1dbnvmdm164PWuhnjn1nhcvFh_qFRP7FRRYFRFKFRFKFRfYFRfsFRc3FRF7FRfsFRcYFRfdFRRvFhkdpvbqnBuVmLKV5HD4nj6vFMDqrHcsP1n1PW9xmLKzFMFB5H0hTMnqniu1uyk_ugFxpyfqniu1pyfqmWm1nW01Phm4Phn3uWNbnzu1IA-b5HDkPiuY5gwsmvkGmvV-ujPxpAnhIAfqn1fLPWR4PBuYUgnqnHRLrjfsnW6drauYIHddn1fLPWR4PBud5y9YIZ0-nYD-nbm-nbuBUAqMFHF7Tv-8miRzwyPEUiRzwyP8FMNGUy-b5Hm3PHR3P1R1niuv5HchpHY1n1-buhF9u6&c=news&cf=1&cvrq=742333&expid=200917_202440_202756_202798&fr=14&fv=0&haacp=138&img_typ=6246&itm=0&lu_idc=nj02&lukid=2&lus=b632036f96c8f5d3&lust=5e14842a&lvl=-1&mscf=0&mtids=2001892614,2015605217&n=10&nttp=1&p=baidu&sr=317&ssp2=1&tpl=baiduCustNativeADImage&tsf=dtp:1&u=%2Fs%2Fblog%5F764b1e9d0102v22a%2Ehtml&uicf=lurecv&urlid=0&eot=1
http://mssp.baidu.com/
javascript:;


2020/1/7 【ENVI入门系列】11.遥感图像监督分类_ENVI-IDL技术殿堂_新浪博客

http://blog.sina.com.cn/s/blog_764b1e9d0102v22a.html 2/8

推荐博文

现代服饰也惊艳

的纯贵妃

中文网站上介绍

为零的小城

苏州红枫甲天下 登高俯瞰克罗地

亚岛城

高原上最古朴的

河湟风情

偶遇侗族采茶妹

谁看过这篇博文

不不要看… 1月6日

勋仔James 1月6日

用户56795… 1月6日

用户19982… 1月3日

用户30370… 1月3日

1282951788 1月3日

mmYY201705 1月3日

拈花不笑 1月2日

用户31384… 1月2日

用户21345… 1月2日

Healer-Q 1月1日

、、碧落 12月31日

更多>>

查看更多>>

本课程以Landsat tm5数据Can_tmr.img为数据源，学习ENVI中的监督分类过程。

2.详细操作步骤

第一步：类别定义/特征判别
根据分类目的、影像数据自身的特征和分类区收集的信息确定分类系统；对影像进行特征判断，评价图像质量，

决定是否需要进行影像增强等预处理。这个过程主要是一个目视查看的过程，为后面样本的选择打下基础。

启动ENVI5.1，打开待分类数据：can_tmr.img。以R:TM Band 5，G: TM Band 4，B：TM Band 3波段组合显

示。

通过目视可分辨六类地物：林地、草地/灌木、耕地、裸地、沙地、其他六类。

第二步：样本选择
（1）在图层管理器Layer Manager中，can_tmr.img图层上右键，选择"New Region Of Interest"，打开

Region of Interest (ROI) Tool面板，下面学习利用选择样本。

1）在Region of Interest (ROI) Tool面板上，设置以下参数：

ROI Name：林地

ROI Color：

图2.1 Region of Interest (ROI) Tool面板上设置样本参数

2）默认ROIs绘制类型为多边形，在影像上辨别林地区域并单击鼠标左键开始绘制多边形样本，一个多边形

绘制结束后，双击鼠标左键或者点击鼠标右键，选择Complete and Accept Polygon，完成一个多边形样

本的选择；

3）同样方法，在图像别的区域绘制其他样本，样本尽量均匀分布在整个图像上；

4）这样就为林地选好了训练样本。

注：1、如果要对某个样本进行编辑，可将鼠标移到样本上点击右键，选择Edit record是修改样本，点击

Delete record是删除样本。

2、一个样本ROI里面可以包含n个多边形或者其他形状的记录（record）。

3、如果不小心关闭了Region of Interest (ROI) Tool面板，可在图层管理器Layer Manager上的某一类样

本（感兴趣区）双击鼠标。

（2）在图像上右键选择New ROI，或者在Region of Interest (ROI) Tool面板上，选择 工

具。重复"林地"样本选择的方法，分别为草地/灌木、耕地、裸地、沙地、其他5类选择样本；

（3）如下图为选好好的样本。

图2.2训练样本的选择

（ 4 ） 计 算 样 本 的 可 分 离 性 。 在 Region of Interest (ROI) Tool 面 板 上 ， 选 择 Option>Compute ROI

Separability，在Choose ROIs面板，将几类样本都打勾，点击OK；

（5）表示各个样本类型之间的可分离性，用Jeffries-Matusita, Transformed Divergence参数表示，这两个参

数的值在0~2.0之间，大于1.9说明样本之间可分离性好，属于合格样本；小于1.8，需要编辑样本或者重新选择

样本；小于1，考虑将两类样本合成一类样本。
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图2.3样本可分离性计算报表

注：1、在图层管理器Layer Manager中，可以选择需要修改的训练样本。

2、在Region of Interest (ROI) Tool面板上，选择Options > Merge (Union/Intersection) ROIs，在

Merge ROIs面板中，选择需要合并的类别，勾选Delete Input ROIs。

 

图2.4 Merge ROIs面板

（6）在图层管理器中，选择Region of interest ，点击右键，save as，保存为.xml格式的样本文件。

注：1、早期版本的感兴趣文件格式为.roi，新版本的为.xml，新版本完全兼容.roi文件，在Region of Interest

(ROI) Tool面板上，选择File>Open打开.xml或.roi文件。

2、新版本的.xml样本文件（感兴趣区文件）可以通过，File>Export>Export to Classic菜单保存为.roi文件。

第三步：分类器选择

根据分类的复杂度、精度需求等确定哪一种分类器。目前ENVI的监督分类可分为基于传统统计分析学的，包括平

行六面体、最小距离、马氏距离、最大似然，基于神经网络的，基于模式识别，包括支持向量机、模糊分类等，

针对高光谱有波谱角（SAM），光谱信息散度，二进制编码。下面是几种分类器的简单描述。

平行六面体（Parallelepiped）

根据训练样本的亮度值形成一个n维的平行六面体数据空间，其他像元的光谱值如果落在平行六面体任何一个训

练样本所对应的区域，就被划分其对应的类别中。

最小距离（Minimum Distance）

利用训练样本数据计算出每一类的均值向量和标准差向量，然后以均值向量作为该类在特征空间中的中心位置，

计算输入图像中每个像元到各类中心的距离，到哪一类中心的距离最小，该像元就归入到哪一类。

马氏距离（Mahalanobis Distance）
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计算输入图像到各训练样本的协方差距离（一种有效的计算两个未知样本集的相似度的方法），最终技术协方差

距离最小的，即为此类别。

最大似然（Maximum Likelihood）

假设每一个波段的每一类统计都呈正态分布，计算给定像元属于某一训练样本的似然度，像元最终被归并到似然

度最大的一类当中。

神经网络（Neural Net）

指用计算机模拟人脑的结构，用许多小的处理单元模拟生物的神经元，用算法实现人脑的识别、记忆、思考过

程。

支持向量机（Support Vector Machine）

支持向量机分类（Support Vector Machine或SVM）是一种建立在统计学习理论（Statistical Learning

Theory或SLT）基础上的机器学习方法。SVM可以自动寻找那些对分类有较大区分能力的支持向量，由此构造出

分类器，可以将类与类之间的间隔最大化，因而有较好的推广性和较高的分类准确率。

波谱角（Spectral Angle Mapper）

它是在N维空间将像元与参照波谱进行匹配，通过计算波谱间的相似度，之后对波谱之间相似度进行角度的对

比，较小的角度表示更大的相似度。

……

第四步：影像分类

基于传统统计分析的分类方法参数设置比较简单，在Toolbox/Classification/Supervised Classification能找到

相应的分类方法。这里选择支持向量机分类方法。在toolbox中选择/Classification/Supervised

Classification/Support Vector Machine Classification，选择待分类影像，点击OK，按照默认设置参数输出

分类结果。

图2.5 支持向量机分类器参数设置

图2.6 支持向量机分类结果

第五步：分类后处理

包括更改类别颜色、分类后统计、小斑块处理、栅矢转换等，这部分专门有一节课讲解。在此不做叙述。

第六步：精度验证

对分类结果进行评价，确定分类的精度和可靠性。有两种方式用于精度验证：一是混淆矩阵，二是ROC曲线，比

较常用的为混淆矩阵，ROC曲线可以用图形的方式表达分类精度，比较抽象。

真实参考源可以使用两种方式：一是标准的分类图，二是选择的感兴趣区（验证样本区）。两种方式的选择都可

以通过主菜单->Classification->Post Classification->Confusion Matrix或者ROC Curves来选择。

真实的感兴趣区验证样本的选择可以是在高分辨率影像上选择，也可以是野外实地调查获取，原则是获取的类别

参考源的真实性。由于没有更高分辨率的数据源，本例中就把原分类的TM影像当作是高分辨率影像，在上面进

行目视解译得到真实参考源。

（1）在Data Manager中，分类样本上右键选择Close，将分类样本从软件中移除
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（2）直接利用ROI工具，跟分类样本选择的方法一样，即重复第二步，在TM图上选择6类验证样本。

注：可直接File>open，打开can_tm-验证样本.roi。

图2.7选择验证样本

（3）在Toolbox中，选择/Classification/Post Classification/Confusion Matrix Using Ground Truth

ROIs，选择分类结果，软件会根据分类代码自动匹配，如不正确可以手动更改。点击OK后选择报表的表示

方法（像素和百分比），点击OK，就可以得到精度报表。

图2.8 验证操作面板

图2.9分类精度评价混淆矩阵

下面对混淆矩阵中的几项评价指标进行说明：

总体分类精度

等于被正确分类的像元总和除以总像元数。被正确分类的像元数目沿着混淆矩阵的对角线分布，总像元数等于所

有真实参考源的像元总数，如本次精度分类精度表中的Overall Accuracy = (1849/2346) 78.8150%。

Kappa系数

它是通过把所有真实参考的像元总数（N）乘以混淆矩阵对角线（XKK）的和，再减去某一类中真实参考像元数

与该类中被分类像元总数之积之后，再除以像元总数的平方减去某一类中真实参考像元总数与该类中被分类像元

总数之积对所有类别求和的结果。
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评论  重要提示：警惕虚假中奖信息

huosf4719

回复(1)

YOUNG2014的春天

回复(0)

用户3046393154

回复(0)

XingYe-Bank

[发评论]

 Kappa计算公式

错分误差

指被分为用户感兴趣的类，而实际属于另一类的像元，它显示在混淆矩阵里面。本例中，林地有419个真实参考

像元，其中正确分类265，12个是其他类别错分为林地（混淆矩阵中林地一行其他类的总和），那么其错分误差

为12/419=2.9%。

漏分误差

指本身属于地表真实分类，当没有被分类器分到相应类别中的像元数。如在本例中的耕地类，有真实参考像元

465个，其中462个正确分类，其余3个被错分为其余类（混淆矩阵中耕地类中一列里其他类的总和），漏分误差

为3/465=0.6%

制图精度

是指分类器将整个影像的像元正确分为A类的像元数（对角线值）与A类真实参考总数（混淆矩阵中A类列的总

和）的比率。如本例中林地有419个真实参考像元，其中265个正确分类，因此林地的制图精度是

265/419=63.25%。

用户精度

是指正确分到A类的像元总数（对角线值）与分类器将整个影像的像元分为A类的像元总数（混淆矩阵中A类行的

总和）比率。如本例中林地有265个正确分类，总共划分为林地的有277，所以林地的用户精度是

265/277=95.67%。

注：监督分类中的样本选择和分类器的选择比较关键。在样本选择时，为了更加清楚的查看地物类型，可以适当

的对图像做一些增强处理，如主成分分析、最小噪声变换、波段组合等操作，便于样本的选择；分类器的选择需

要根据数据源和影像的质量来选择，比如支持向量机对高分辨率、四个波段的影像效果比较好。
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